Apache

うちのサーバはApacheですが、先ほど1.3.22から1.3.23にアップしました。sslをサポートするためにmod_sslというのが必要で、これが1.3.23に対応するのを待って行ったんですが、それで思ったのは、色々モジュールを追加している場合、それらがバージョンアップするのを待たないとならないこともあるということ。もちろん出来る限り最新のバージョンを使うのが良いんですが、モジュールなどで複雑な依存関係がある場合は難しいですねぇ。ちなみに他のモジュールも追加していて、HTTPのヘッダを見ると

Server: Apache/1.3.23 (Unix) mod_auth_pgsql/0.9.11 DAV/1.0.2PHP/4.1.1 mod_ssl/2.8.6 OpenSSL/0.9.6c

となってます。rcなどを除けば最新バージョンで揃ってます。さらにphpで利用しているモジュールもあるのでバージョン管理が少しずつ大変になってきてます。

コメント

タイトルとURLをコピーしました